Multiplayer Help

Annoying as HELL!

By stupidmonkey 6 years ago

OK, so when I try to join a multiplayer game it barely ever works. It will either load me into the lobby and then immediately kick me, or it will just say loading and once it's done it goes straight back to the multiplayer search screen. It rarely ever actually lets me join a game. I'm getting extremely frustrated, so do any of you guys know how to fix this?

This is for GTA IV, by the way.

Update: Now it won't even let me get to the browsing screen for multiplayer. It just says that I'm not logged on to live, but I am.

9 posts 1,713 views
  • You must be a member

Replies

  • stupidmonkey's Levels
    • P2: Drudge
      Points: 5,223
    • A6: Elder
      Account Age: 7 years
    6 years ago:

    30 minute bump before I go to bed.

    User Title
    We all have a little monkey in
  • Randypp's Levels
    • P1: Beggar
      Points: 265
    • E1: Helper
      EF: 1
    • A6: Elder
      Account Age: 6 years
    6 years ago:

    You have the newest version/patch? If there is even a patch for this. And wrong section. btw.

    Son, i am approval.
  • Gibez's Levels
    • P1: Beggar
      Points: 73
    • E1: Helper
      EF: 4
    • A6: Elder
      Account Age: 6 years
    6 years ago:
    Posted by Eagle.
    Posted by Spartan 172 You have the newest version/patch? If there is even a patch for this. And wrong section. btw.
    do you see a gta4 section?
    This is the GTA4 section. Though it's bugggged. (what a surprise --_--")

    I correct that; here is the GTA4 section.

  • stupidmonkey's Levels
    • P2: Drudge
      Points: 5,223
    • A6: Elder
      Account Age: 7 years
    6 years ago:
    Posted by Gibez This is the GTA4 section. Though it's bugggged. (what a surprise --_--") I correct that; here is the GTA4 section.

    When I added to the GTA IV section, it fucks up and adds it to some random game nobody plays.

    Now can we please stay on topic here?

    User Title
    We all have a little monkey in
  • Ankh's Levels
    • P3: Peasant
      Points: 16,820
    • E1: Helper
      EF: 4
    • A6: Elder
      Account Age: 9 years
    Username
    Ankh
    6 years ago:
    Posted by stupidmonkey
    Posted by Gibez This is the GTA4 section. Though it's bugggged. (what a surprise --_--") I correct that; here is the GTA4 section.
    When I added to the GTA IV section, it fucks up and adds it to some random game nobody plays. Now can we please stay on topic here?

    Are you trying to start a LAN game through hamachi with friends? Or just a public server?

    User Title
  • Gone's Levels
    • P1: Beggar
      Points: 5
    • A6: Elder
      Account Age: 8 years
    6 years ago:

    I had this happening, it was the NAT settings on my router, they were too strict. So I had to turn my router firewall off and put my computer on a DMZ for it to work.

  • KniteWulf's Levels
    • P1: Beggar
      Points: 41
    • E1: Helper
      EF: 19
    • A6: Elder
      Account Age: 8 years
    Username
    KniteWulf
    6 years ago:
    Posted by stupidmonkey
    Posted by Gibez This is the GTA4 section. Though it's bugggged. (what a surprise --_--") I correct that; here is the GTA4 section.
    When I added to the GTA IV section, it fucks up and adds it to some random game nobody plays. Now can we please stay on topic here?

    To let you know, you need to be on RPGBanana to add it to the GTA IV section, and it will randomly move it about into other games if you edit it while on FPSBanana.

    On topic: It's simply the way GTA IV works. The lobby system is inherently flawed and extremely hard to navigate, even after 160 hours of gameplay. It took me 120 hours to figure out that to create a ranked match I had to go to Quick Match in the phone and hope I got an empty lobby. Aside from the obvious, try looking at your router and computer settings; you could need to port forward or disable a program that's interfering with GTA IV.

    User Title
    Forgotten
  • stupidmonkey's Levels
    • P2: Drudge
      Points: 5,223
    • A6: Elder
      Account Age: 7 years
    6 years ago:
    Posted by Ankh Are you trying to start a LAN game through hamachi with friends? Or just a public server?

    I'm trying to play on servers, this doesn't have to do with making servers.

    Also, thanks for everyone's advice so far. I hate forwarding ports, though.

    User Title
    We all have a little monkey in
  • stupidmonkey's Levels
    • P2: Drudge
      Points: 5,223
    • A6: Elder
      Account Age: 7 years
    6 years ago:

    Alright, now it won't even let me get to the browsing screen for multiplayer. It says I'm not logged into live, which I am.

    User Title
    We all have a little monkey in
  • You must be a member